time-varying individual covariates and padded values

questions concerning analysis/theory using program MARK

time-varying individual covariates and padded values

Postby Eurycea » Thu Sep 21, 2023 3:27 pm

I'm trying to troubleshoot some unexpected behavior in my models. I'm running some multi-state models with a binary time-varying covariate (0 and 1 for two size classes). I understand for a time-varying individual covariate I need a value for every animal on every occasion, but I assume that is only applicable from the first capture forward. Is that correct for multi-state models?

For occasions prior to the first capture, I simply have provided a padded value because MARK does not want a dot or NA in that place. So for example, if I used 9 as a pad, the size covariate matrix for an individual first captured on the 2nd occasion of 4 might look something like this: 9 0 0 1 and that could have a corresponding capture history of 0101 or 0111 or 0100.

To make sure my padded values actually don't make any difference, I started playing around. Here's where things get weird. If I pad the covariate values with 0, 1, 9 and 99 to compare the differences, I get the same results for all examples using the standard optimization routine. However, if I use simulated annealing, I get different results, but only for data padded with 9 or 99. Are those values sneaking into the likelihood? I cannot figure out what is going on. What am I missing here?

https://photos.smugmug.com/Site-Pages/S ... 142450.png

Edited to add: I have checked this same dataset with a basic CJS model and I'm encountering the same problem in the same way. I have triple-checked my data also and cannot find any instances where I inadvertently have an observation in the capture history prior to a size estimate. I'm going to see if there's a published or example dataset I can test this on.
Eurycea
 
Posts: 99
Joined: Thu Feb 25, 2010 11:21 am

Re: time-varying individual covariates and padded values

Postby Eurycea » Fri Sep 22, 2023 9:00 am

Ok I think I figured this out...

I think what is happening is related to the standardization of the design matrix. Here's what the Good Book says:

"What about the second option – ‘Do not standardize (the) design matrix’? As noted in the
MARK help file, it is often helpful to scale the values of the covariates to ensure that the numerical
optimization algorithm finds the correct parameter estimates. The current version of MARK defaults
to scaling your covariate data for you automatically (without you even being aware of it). This ‘automatic
scaling’ is done by determining the maximum absolute value of the covariates, and then dividing each
covariate by this value. This results in each column scaled to between -1 and 1. This internal scaling
is purely for purposes of ensuring the success of the numerical optimization – the parameter values
reported by MARK (i.e., in the output that you see) are ‘back-transformed’ to the original scale. There
may be reasons you don’t want MARK to perform this ‘internal standardization’ – if so, you simply
check the ‘Do not standardize (the) design matrix’ button."

So I'm thinking when I add values of 9 or 99 this does some wonky things because it probably scales the entire column of covariate data. I'm not sure why it lands on a different answer, but at least this would explain why padded values of 1 or 0 don't change anything and why higher values do. After checking the "do not standardize DM" box I am now getting results that are congruent no matter the padded value or optimization routine.
Eurycea
 
Posts: 99
Joined: Thu Feb 25, 2010 11:21 am


Return to analysis help

Who is online

Users browsing this forum: No registered users and 1 guest

cron