Problem with constraint matrix file

announcements (new versions, changes, bugs, installation problems...) related to M-SURGE, E-SURGE and U-CARE

Problem with constraint matrix file

Postby TimG » Thu Feb 21, 2019 12:46 pm

Using Gepat, I’ve set up a model with 1 step for initial state, 2 steps for transition (survival and movement), and 2 steps for event (capture and state assignment). I am able to run a model constructed with the ‘model definition language’ in Gemaco. This model runs without error, has the correct/expected number of beta parameters, and returns reasonable parameter estimates.

However, I get an error when I try to run a different model, using a constraint matrix (.mm) file for the 2nd transition step. This .mm file seems to be read in correctly (the black DOS window updates and the constraint matrix is displayed correctly in the Gemaco interface). But once I exit Gemaco, I get an error message:
"Index exceeds matrix dimensions.
Error in modme/constraint (line 166) ..."

Even more strange: I saved the constraint matrix (.mm) file for this step from the first model that ran without error. I tried to run the first model again, but nothing seems to happen when I load in this unedited .mm file (the DOS window does not update and the constraint matrix is not displayed). After exiting Gemaco, I get the ‘index exceeds matrix dimensions’ error as above.

I have not had any issues using .mm files before, and it seems like the problem is only for this 2nd transition step (I can successfully load in .mm files for the survival and capture steps of this model).

Thanks in advance.
TimG
 
Posts: 9
Joined: Mon Aug 31, 2015 12:37 pm

Return to software problems/news

Who is online

Users browsing this forum: No registered users and 2 guests

cron