Using RMark in R Shiny

announcements (new versions, changes, bugs, installation problems...) related to program MARK

Using RMark in R Shiny

Postby danikaschube » Sat Feb 04, 2023 2:45 pm

Hi,
I have used RMark for many years in R and am familiar with how it works on the regular R platform and in R studio. I have created an app in R Shiny that works on my desktop. However, when I pull it up to shinyapps.io I get the error message that mark cannot be found. For example, the log says:
....
Phi.dot.p.fixed.Lambda.dot
sh: 1: mark: not found

I have set the Markpath in shiny to:
MarkPath <<-"www/"

As I mentioned above, this works on my desktop but for some reason it can't find the mark.exe file (either mark32.exe or mark64.exe) when I pull it up. I have included both these files in my upload.

I think there is something I am doing wrong when setting the path in the upload.

Thank you in advance for any help you can give. If you need more information, I am happy to provide it.

Danielle
danikaschube
 
Posts: 4
Joined: Thu Jun 12, 2003 4:07 pm
Location: The Institute for Bird Populations

Re: Using RMark in R Shiny

Postby jlaake » Sat Feb 04, 2023 3:02 pm

Most likely looking for mark.exe on the shiny server. You'll need to set MarkPath variable to your local location for mark.exe. Not how that will interact with shiny. Do a search on shiny apps that work with external software.

Jeff
jlaake
 
Posts: 1411
Joined: Fri May 12, 2006 12:50 pm
Location: Escondido, CA


Return to software problems/news

Who is online

Users browsing this forum: No registered users and 1 guest

cron