Plot mismatch in occupancy heterogeneity model

announcements (new versions, changes, bugs, installation problems...) related to program MARK

Plot mismatch in occupancy heterogeneity model

Postby AGChiarello » Wed Nov 27, 2019 10:32 am

I am using the Royle & Nichols (2003) parametrization in MARK, in which heterogeneity in detection is caused by variation in individual abundance between camera trap stations for a giant anteater occupancy study. The top model has a constant detection (r(.)) and a continuous covariate for lambda (edge density). When I try to plot the relationship between edge density (x) and lambda (y) I notice that the y axis is always constrained between 0 and 1. However, the average lambda estimated for this top-ranked model is substantially larger (lambda=2.26). I have tried using other models having different continuous covariates for lambda, but the plot produced by MARK (individual covariate plot) always report lambda in the y axis in the range 0-1, notwithstangind the estimated average lambda being larger. Inspecting the results in Excel I notice that what MARK is outputing as estimated lambda is "EXP(equation)/1+EXP(equation)" while it should be "EXP(equation)" since the link function for lambda is log, not logit. Am I right? Thanks!
AGChiarello
 
Posts: 2
Joined: Mon Nov 25, 2019 8:20 pm

Re: Plot mismatch in occupancy heterogeneity model

Postby gwhite » Wed Nov 27, 2019 7:19 pm

You are correct that lambda should have the log link function applied, with exp() the back transformation. The lambda parameter is one of several that the numerical code knows to use the log link with even though you have specified the logit link. Unfortunately, the plotting code isn't that smart.

So you can handle this in 2 different ways. First, if the problem is well-behaved, you could specify the log link as the default. The r parameter will be correctly estimated IF if isn't at the boundary of 1.

However, the second and preferred approach is to use the parameter-specific link function, specifying logit for r and log for lambda. You will get exactly the same model as if you has specified logit for all parameters, but now the plot package will know to use log/exp for the lambda parameter.

Gary
gwhite
 
Posts: 291
Joined: Fri May 16, 2003 9:05 am

Re: Plot mismatch in occupancy heterogeneity model

Postby AGChiarello » Thu Nov 28, 2019 6:50 am

Thanks Gary! I have tried the parameter specific alternative you suggested, which corrected the problem perfectly. All the best, AGChiarello.
AGChiarello
 
Posts: 2
Joined: Mon Nov 25, 2019 8:20 pm


Return to software problems/news

Who is online

Users browsing this forum: No registered users and 1 guest

cron